ipcalc — IPv4 calculator online

Network summary

Address
—
Netmask
—
Netmask (hex)
—
Network
—
Broadcast
—
Host min
—
Host max
—
Hosts/net
—

Binary view

—
—
—
—

Special RFC ranges

This app flags RFC 1918 (private), RFC 3927 (link-local), RFC 5735 (special-use), and RFC 5737 (documentation) ranges.